当前位置:网站首页 / 技术杂谈 / 正文

No PostCSS Config found in……

时间:2019年06月06日 | 作者 : 张端建 | 分类 : 技术杂谈 | 浏览: 1535次 | 评论 0

前言:最近手撸vue项目搭建webpack环境时看的一个视频教程,奈何视频太久远,许多版本已经停止维护,不得不去找新版本,这里分享一个错误。

错误:

ERROR in ./node_modules/mint-ui/lib/style.css (./node_modules/css-loader/dist/cjs.js!./node_modules/postcss-loader/src!./node_modules/mint-ui/lib/style.css)
Module build failed (from ./node_modules/postcss-loader/src/index.js):
`Error: No PostCSS Config found in: C:\Users\32193\Desktop\vue_project\node_modules\mint-ui\lib`
    at config.load.then (C:\Users\32193\Desktop\vue_project\node_modules\postcss-load-config\src\index.js:55:15)
 @ ./node_modules/mint-ui/lib/style.css 2:14-101
 @ ./src/main.js

解决:

在项目根目录创建post.config.js文件,文件内容如下:

module.exports = {
    plugins: {
        'autoprefixer': {browsers: 'last 5 version'}
    }
}

重新打包(npm run dev)即可解决postcss问题。

其实这个配置文件在官方文档中已经说了,毕竟第一次用看不懂还是可以原谅的,hhh。

可能有人不知道在webpack.config.js中怎么配置,这里我将配置和版本附给大家

附:

webpack.config.js

            {
                test: /\.css$/,
                loader: 'style-loader!css-loader!postcss-loader'
            },
            {
                test: /\.less$/,
                loader: 'style-loader!css-loader!postcss-loader!less-loader'
            },

版本:

"css-loader": "^2.1.1",
"less": "^3.9.0",
"less-loader": "^5.0.0",
"postcss-loader": "^3.0.0",
"style-loader": "^0.23.1"

推荐您阅读更多有关于“postcss-loadernpm,”的文章

请在这里放置你的在线分享代码

猜你喜欢

额 本文暂时没人评论 来添加一个吧

发表评论

必填

选填

选填

◎欢迎参与讨论,请在这里发表您的看法、交流您的观点。